mirror of
https://github.com/haiwen/libsearpc.git
synced 2025-04-28 02:30:08 +00:00
15 lines
385 B
Makefile
Executable File
15 lines
385 B
Makefile
Executable File
#!/usr/bin/make -f
|
|
# -*- makefile -*-
|
|
|
|
%:
|
|
dh $@ --with python3 --with autotools_dev --builddirectory=build
|
|
|
|
override_dh_auto_configure:
|
|
./autogen.sh
|
|
dh_auto_configure -- --disable-compile-demo
|
|
|
|
override_dh_strip:
|
|
# emptying the dependency_libs field in .la files
|
|
sed -i "/dependency_libs/ s/'.*'/''/" `find debian/ -name '*.la'`
|
|
dh_strip -plibsearpc1 --dbg-package=libsearpc-dbg
|